NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Passport vulnerable to session regeneration when a users logs in or outGHSA-v923-w3x8-wh69

MEDIUMFix: jaredhanson/passport#900

GHSA-v923-w3x8-wh69 is a medium-severity (CVSS 4.8) CWE-384 vulnerability in passport. A fix is available for passport — see the affected versions and patch details below.

Also known asCVE-2022-25896SNYK-JS-PASSPORT-2840631
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.08%1.62%0.2%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

7Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
passportnpm
10.2Mdownloads / week

Description

This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmpassportall versions0.6.0npm install passport@0.6.0

Affected Products

1 product · 1 configurations
Application
passportpassport_project
< 0.6.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for passport, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update passport to 0.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v923-w3x8-wh69 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for GHSA-v923-w3x8-wh69 (CC BY 4.0)

Frequently Asked Questions

This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
O3 Security · Impact-Aware SCA

Is GHSA-v923-w3x8-wh69 in your dependencies?

Find it across npm, including transitive dependencies.

Passport vulnerable to session regeneration when a users…