CVE-2026-69214 is a medium-severity (CVSS 6.8) CWE-384 vulnerability in org.http4s:http4s-client_2.12. A fix is available for org.http4s:http4s-client_2.12 — see the affected versions and patch details below.
Http4s: CookieJar middleware accepts arbitrary Set-Cookie domain
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-69214.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.http4s:http4s-client_2.12☕org.http4s:http4s-client_2.13☕org.http4s:http4s-client_2.13☕org.http4s:http4s-client_3☕org.http4s:http4s-client_3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When processing a Set-Cookie from a response, the CookieJar client middleware trusts the server-supplied Domain attribute verbatim, with no check that it domain-matches the host that sent the cookie (RFC6265 §5.3 step 6) and no public suffix check. A malicious or compromised server can therefore plant a cookie for any domain in the cookie jar, which is subsequently set on the client's next request to that victim domain, enabling session fixation or overwriting security-relevant cookies.
Impact
Session fixation and overwrite of security-relevant cookies for arbitrary domains contacted by the same wrapped client.
Preconditions
- Application uses the
CookieJarclient middleware. - Application contacts an attacker-controlled (or compromised) server using the same jar it uses for trusted hosts.
Workarounds
- Do not share a
CookieJaracross trusted and untrusted targets.
Note
This middleware still does not implement public suffix rejection.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.http4s:http4s-client_2.12 | all versions | 0.23.35org.http4s:http4s-client_2.12:0.23.35 |
| ☕Maven | org.http4s:http4s-client_2.13 | all versions | 0.23.35org.http4s:http4s-client_2.13:0.23.35 |
| ☕Maven | org.http4s:http4s-client_2.13 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-client_2.13:1.0.0-M47 |
| ☕Maven | org.http4s:http4s-client_3 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-client_3:1.0.0-M47 |
| ☕Maven | org.http4s:http4s-client_3 | all versions | 0.23.35org.http4s:http4s-client_3:0.23.35 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.http4s:http4s-client_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.http4s:http4s-client_2.12 to 0.23.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-69214 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2026-69214 in your dependencies?
Find it across Maven, including transitive dependencies.