CVE-2026-69215 is a medium-severity (CVSS 6.8) CWE-565 vulnerability in org.http4s:http4s-client_2.12. A fix is available for org.http4s:http4s-client_2.12 — see the affected versions and patch details below.
Http4s: CookieJar middleware matches by substring, leaking cookies cross-origin
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-69215.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.http4s:http4s-client_2.12☕org.http4s:http4s-client_2.13☕org.http4s:http4s-client_3☕org.http4s:http4s-client_2.13☕org.http4s:http4s-client_3Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The CookieJar client middleware decides whether to attach a cookie to an outgoing request using an unanchored substring test on the host and path, instead of the domain match specified by RFC6265 5.1.3. A cookie stored for example.com is therefore sent to any host whose name merely contains example.com (e.g. evilexample.com), leaking potentially sensitive cookies to an attacker-chosen host.
Impact
Disclosure of session and authentication cookies to an attacker-controlled host, enabling session hijack of the application's outbound calls.
Preconditions
- Application uses the
CookieJarclient middleware. - Application can be induced to make an outbound request to a host controlled by the attacker, where the hostname contains the targeted domain as a substring.
Workarounds
- Do not use the
CookieJarwith clients that fetch attacker-influenced URLs - Apply a separate
CookieJarper trusted origin.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.http4s:http4s-client_2.12 | all versions | 0.23.35org.http4s:http4s-client_2.12:0.23.35 |
| ☕Maven | org.http4s:http4s-client_2.13 | all versions | 0.23.35org.http4s:http4s-client_2.13:0.23.35 |
| ☕Maven | org.http4s:http4s-client_3 | all versions | 0.23.35org.http4s:http4s-client_3:0.23.35 |
| ☕Maven | org.http4s:http4s-client_2.13 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-client_2.13:1.0.0-M47 |
| ☕Maven | org.http4s:http4s-client_3 | ≥ 1.0.0-M1&&< 1.0.0-M47 | 1.0.0-M47org.http4s:http4s-client_3:1.0.0-M47 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.http4s:http4s-client_2.12, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.http4s:http4s-client_2.12 to 0.23.35 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-69215 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2026-69215 in your dependencies?
Find it across Maven, including transitive dependencies.