CVE-2022-25896 is a medium-severity (CVSS 4.8) CWE-384 vulnerability in passport. A fix is available for passport — see the affected versions and patch details below.
Session Fixation
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
passportnpmDescription
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | passport | all versions | 0.6.0npm install passport@0.6.0 |
Affected Products
passportpassport_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for passport, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update passport to 0.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25896 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.Source: Red Hat security advisory for CVE-2022-25896 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2022-25896 in your dependencies?
Find it across npm, including transitive dependencies.