TinyMCE vulnerable to mutation Cross-site Scripting via special characters in unescaped text nodesGHSA-v626-r774-j7f8
MEDIUMGHSA-v626-r774-j7f8 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in tinymce. A fix is available for tinymce — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-v626-r774-j7f8.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
tinymcenpmDescription
Impact
A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo/redo functionality and other APIs and plugins. Text nodes within specific parents are not escaped upon serialization according to the HTML standard. If such text nodes contain a special character reserved as an internal marker, they can be combined with other HTML patterns to form malicious snippets. These snippets pass the initial sanitisation layer when the content is parsed into the editor body, but can trigger XSS when the special internal marker is removed from the content and re-parsed. Such mutations occur when serialised HTML content is processed before being stored in the undo stack, or when the following APIs and plugins are used:
Patches
This vulnerability has been patched in TinyMCE 6.7.3 by:
- ensuring that any unescaped text nodes which contain the special internal marker are emptied before removing the marker from the rest of the HTML, and
- removing the special internal marker from content strings passed to
Editor.setContent,Editor.insertContent, andEditor.resetContentAPIs to prevent them from being loaded into the editor as user-provided content.
Fix
To avoid this vulnerability:
- Upgrade to TinyMCE 6.7.3 or higher for TinyMCE 6.x.
- Upgrade to TinyMCE 5.10.9 or higher for TinyMCE 5.x.
Acknowledgements
Tiny Technologies would like to thank Masato Kinugawa of Cure53 for discovering this vulnerability.
References
For more information
Email us at [email protected] Open an issue in the TinyMCE repo
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | tinymce | all versions | 5.10.9npm install tinymce@5.10.9 |
| 📦npm | tinymce | ≥ 6.0.0&&< 6.7.3 | 6.7.3npm install tinymce@6.7.3 |
| .NETNuGet | TinyMCE | all versions | 5.10.9dotnet add package TinyMCE --version 5.10.9 |
| .NETNuGet | TinyMCE | ≥ 6.0.0&&< 6.7.3 | 6.7.3dotnet add package TinyMCE --version 6.7.3 |
| 🐘Packagist | tinymce/tinymce | all versions | 5.10.9composer require tinymce/tinymce:^5.10.9 |
| 🐘Packagist | tinymce/tinymce | ≥ 6.0.0&&< 6.7.3 | 6.7.3composer require tinymce/tinymce:^6.7.3 |
Affected Products
tinymcetinyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tinymce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tinymce to 5.10.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-v626-r774-j7f8 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-v626-r774-j7f8 in your dependencies?
Find it across npm, NuGet, Packagist, including transitive dependencies.