CVE-2026-116675 — tinymce
Fix: tinymce/tinymce@bd1ab5eCVE-2026-116675 is a Cross-site Scripting (XSS) vulnerability in tinymce. A fix is available for tinymce — see the affected versions and patch details below.
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-116675.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
tinymce📦tinymce.NETTinyMCE.NETTinyMCE🐘tinymce/tinymce🐘tinymce/tinymceReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects npm, NuGet packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.
Patches
This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first.
Workarounds
No official workaround available.
Fix
To avoid this vulnerability:
Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher.
Acknowledgements
Tiny thanks Fariskhi Vidyan and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | tinymce | ≥ 8.5.1&&< 8.9.3 | 8.9.3npm install tinymce@8.9.3 |
| 📦npm | tinymce | ≥ 7.9.3&&< 7.9.4 | 7.9.4npm install tinymce@7.9.4 |
| .NETNuGet | TinyMCE | ≥ 8.5.1&&< 8.9.3 | 8.9.3dotnet add package TinyMCE --version 8.9.3 |
| .NETNuGet | TinyMCE | ≥ 7.9.3&&< 7.9.4 | 7.9.4dotnet add package TinyMCE --version 7.9.4 |
| 🐘Packagist | tinymce/tinymce | ≥ 8.5.1&&< 8.9.3 | 8.9.3composer require tinymce/tinymce:^8.9.3 |
| 🐘Packagist | tinymce/tinymce | ≥ 7.9.3&&< 7.9.4 | 7.9.4composer require tinymce/tinymce:^7.9.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tinymce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tinymce to 8.9.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-116675 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-116675 in your dependencies?
Find it across npm, NuGet, Packagist, including transitive dependencies.