Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
📦 npm.NET NuGet🐘 Packagist
Not in CISA KEV

TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serializationGHSA-mf2p-h6hf-fcwm

Fix: tinymce/tinymce@bd1ab5e

GHSA-mf2p-h6hf-fcwm is a Cross-site Scripting (XSS) vulnerability in tinymce. A fix is available for tinymce — see the affected versions and patch details below.

Also known asCVE-2026-116675
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-mf2p-h6hf-fcwm.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs28th percentile — riskier than 28% of all scored CVEsHighest risk

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

6 pkgs affected
📦tinymce📦tinymce.NETTinyMCE.NETTinyMCE🐘tinymce/tinymce🐘tinymce/tinymce

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects npm, NuGet packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.

Patches

This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first.

Workarounds

No official workaround available.

Fix

To avoid this vulnerability:

Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher.

Acknowledgements

Tiny thanks Fariskhi Vidyan and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
📦npmtinymce≥ 8.5.1&&< 8.9.38.9.3npm install tinymce@8.9.3
📦npmtinymce≥ 7.9.3&&< 7.9.47.9.4npm install tinymce@7.9.4
.NETNuGetTinyMCE≥ 8.5.1&&< 8.9.38.9.3dotnet add package TinyMCE --version 8.9.3
.NETNuGetTinyMCE≥ 7.9.3&&< 7.9.47.9.4dotnet add package TinyMCE --version 7.9.4
🐘Packagisttinymce/tinymce≥ 8.5.1&&< 8.9.38.9.3composer require tinymce/tinymce:^8.9.3
🐘Packagisttinymce/tinymce≥ 7.9.3&&< 7.9.47.9.4composer require tinymce/tinymce:^7.9.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tinymce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tinymce to 8.9.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mf2p-h6hf-fcwm is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled. ### Patches This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first. ### Workarounds No official workaround available. ### Fix To avoid this vulnerability: Upgrade to TinyMCE 8.9.3 or
O3 Security · Impact-Aware SCA

Is GHSA-mf2p-h6hf-fcwm in your dependencies?

Find it across npm, NuGet, Packagist, including transitive dependencies.

TinyMCE Cross-Site Scripting (XSS) vulnerability using…