NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm.NET NuGet🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2023-48219 — tinymce

MEDIUM

CVE-2023-48219 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in tinymce. A fix is available for tinymce — see the affected versions and patch details below.

Special characters in unescaped text nodes can trigger mXSS in TinyMCE

Also known asGHSA-v626-r774-j7f8
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-48219.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.14%1.16%2.18%3.19%2.6%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

1Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
tinymcenpm
1.5Mdownloads / week

Description

Impact

A mutation cross-site scripting (mXSS) vulnerability was discovered in TinyMCE’s core undo/redo functionality and other APIs and plugins. Text nodes within specific parents are not escaped upon serialization according to the HTML standard. If such text nodes contain a special character reserved as an internal marker, they can be combined with other HTML patterns to form malicious snippets. These snippets pass the initial sanitisation layer when the content is parsed into the editor body, but can trigger XSS when the special internal marker is removed from the content and re-parsed. Such mutations occur when serialised HTML content is processed before being stored in the undo stack, or when the following APIs and plugins are used:

Patches

This vulnerability has been patched in TinyMCE 6.7.3 by:

  • ensuring that any unescaped text nodes which contain the special internal marker are emptied before removing the marker from the rest of the HTML, and
  • removing the special internal marker from content strings passed to Editor.setContent, Editor.insertContent, and Editor.resetContent APIs to prevent them from being loaded into the editor as user-provided content.

Fix

To avoid this vulnerability:

  • Upgrade to TinyMCE 6.7.3 or higher for TinyMCE 6.x.
  • Upgrade to TinyMCE 5.10.9 or higher for TinyMCE 5.x.

Acknowledgements

Tiny Technologies would like to thank Masato Kinugawa of Cure53 for discovering this vulnerability.

References

For more information

Email us at [email protected] Open an issue in the TinyMCE repo

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
📦npmtinymceall versions5.10.9npm install tinymce@5.10.9
📦npmtinymce≥ 6.0.0&&< 6.7.36.7.3npm install tinymce@6.7.3
.NETNuGetTinyMCEall versions5.10.9dotnet add package TinyMCE --version 5.10.9
.NETNuGetTinyMCE≥ 6.0.0&&< 6.7.36.7.3dotnet add package TinyMCE --version 6.7.3
🐘Packagisttinymce/tinymceall versions5.10.9composer require tinymce/tinymce:^5.10.9
🐘Packagisttinymce/tinymce≥ 6.0.0&&< 6.7.36.7.3composer require tinymce/tinymce:^6.7.3

Affected Products

1 product · 2 configurations
Application
tinymcetiny
≥ 6.0.0 && < 6.7.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tinymce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tinymce to 5.10.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-48219 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact A [mutation cross-site scripting](https://researchgate.net/publication/266654651_mXSS_attacks_Attacking_well-secured_web-applications_by_using_innerHTML_mutations) (mXSS) vulnerability was discovered in TinyMCE’s core undo/redo functionality and other APIs and plugins. Text nodes within specific parents are not escaped upon serialization according to the [HTML standard](https://html.spec.whatwg.org/multipage/parsing.html#serialising-html-fragments). If such text nodes contain a special character reserved as an internal marker, they can be combined with other HTML patterns to form ma
O3 Security · Impact-Aware SCA

Is CVE-2023-48219 in your dependencies?

Find it across npm, NuGet, Packagist, including transitive dependencies.

CVE-2023-48219: tinymce XSS — Fixed in 5.10.9