Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
🐍 PyPI
CISA KEV · ACTIVELY EXPLOITED

Langflow Unauth RCEGHSA-rvqx-wpfh-mfx7

Fix: langflow-ai/langflow#6911

GHSA-rvqx-wpfh-mfx7 is a Missing Authentication vulnerability in langflow. It is in CISA's Known Exploited Vulnerabilities catalog (added 2025-05-05) and has been used in ransomware campaigns — treat it as actively exploited and patch now. A fix is available for langflow — see the affected versions and patch details below.

Also known asCVE-2025-3248PYSEC-2025-36PYSEC-2026-380
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
11 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, CISA KEV, FIRST.org (EPSS)

Exploitation Status

Actively exploited in the wild

  • Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2025-05-05 — including use in ransomware campaigns. Federal agencies were required to remediate by 2025-05-26.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA (KEV catalog and SSVC triage) for GHSA-rvqx-wpfh-mfx7.

EPSS Exploitation Probability

via FIRST.org ↗
100.0%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
89.3%92.9%96.4%100.0%92.1%100.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
🐍langflow🐍langflow-base

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIlangflowall versions1.3.0pip install --upgrade 'langflow==1.3.0'
🐍PyPIlangflow-baseall versions0.3.0pip install --upgrade 'langflow-base==0.3.0'

Affected Products

1 product · 1 configurations
Application
langflowlangflow
< 1.3.0
range
Exploits & PoCs
11

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-52262remotemultiple

Langflow 1.3.0 - Remote Code Execution (RCE)

by VeryLazyTech · Apr 18, 2025

EDB-52364webappsmultiple

Langflow 1.2.x - Remote Code Execution (RCE)

by Raghad Abdallah Al-syouf · Jul 16, 2025

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for langflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update langflow to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rvqx-wpfh-mfx7 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect GHSA-rvqx-wpfh-mfx7

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id ghsa-rvqx-wpfh-mfx7 -u https://target
Template
Langflow AI - Unauthenticated Remote Code Execution
Severity
critical
Impact
Unauthenticated attackers can execute arbitrary code through crafted POST requests to the /api/v1/validate/code endpoint, achieving complete server compromise.
Remediation
Upgrade to Langflow version 1.3.0 or later that properly validates user input before passing it to code execution functions.

Template by ProjectDiscovery nuclei-templates (nvn1729), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.
O3 Security · Impact-Aware SCA

Is GHSA-rvqx-wpfh-mfx7 in your dependencies?

Find it across PyPI, including transitive dependencies.

Langflow Unauth RCE