CVE-2025-3248 is a critical-severity (CVSS 9.8) Missing Authentication vulnerability in langflow. It is in CISA's Known Exploited Vulnerabilities catalog (added 2025-05-05) and has been used in ransomware campaigns — treat it as actively exploited and patch now. A fix is available for langflow — see the affected versions and patch details below.
Langflow < 1.3.0 Unauthenticated RCE via /api/v1/validate/code
Exploitation Status
Actively exploited in the wild
- Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2025-05-05 — including use in ransomware campaigns. Federal agencies were required to remediate by 2025-05-26.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA (KEV catalog and SSVC triage) for CVE-2025-3248.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2025-3248 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).
Where this sits among everything scored
Of 396,257 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
langflow🐍langflow-baseReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Langflow versions prior to 1.3.0 are susceptible to code injection in the /api/v1/validate/code endpoint. A remote and unauthenticated attacker can send crafted HTTP requests to execute arbitrary code.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | langflow | all versions | 1.3.0pip install --upgrade 'langflow==1.3.0' |
| 🐍PyPI | langflow-base | all versions | 0.3.0pip install --upgrade 'langflow-base==0.3.0' |
Affected Products
langflowlangflowResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Langflow 1.3.0 - Remote Code Execution (RCE)
by VeryLazyTech · Apr 18, 2025
Langflow 1.2.x - Remote Code Execution (RCE)
by Raghad Abdallah Al-syouf · Jul 16, 2025
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for langflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update langflow to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-3248 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
How to detect CVE-2025-3248
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2025-3248 -u https://target- Template
- Langflow AI - Unauthenticated Remote Code Execution
- Severity
- critical
- Impact
- Unauthenticated attackers can execute arbitrary code through crafted POST requests to the /api/v1/validate/code endpoint, achieving complete server compromise.
- Remediation
- Upgrade to Langflow version 1.3.0 or later that properly validates user input before passing it to code execution functions.
Template by ProjectDiscovery nuclei-templates (nvn1729), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2025-3248 in your dependencies?
Find it across PyPI, including transitive dependencies.