NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 SwiftURL
Not in CISA KEV

LeafKit allows XSS with untrusted user inputGHSA-rv3x-xq3r-8j9h

GHSA-rv3x-xq3r-8j9h is a Cross-site Scripting (XSS) vulnerability in github.com/vapor/leaf-kit. A fix is available for github.com/vapor/leaf-kit — see the affected versions and patch details below.

Also known asCVE-2021-37634
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.40%0.81%1.21%0.3%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
📦github.com/vapor/leaf-kit

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects SwiftURL packages — download data is not available via public APIs for these ecosystems.

Description

Impact

This affects anyone passing unsanitised data to Leaf's variable tags. Before this fix, Leaf would not escape any strings passed to tags as variables. If an attacker managed to find a variable that was rendered with their unsanitised data, they could inject scripts into a generated Leaf page, which could enable XSS attacks if other mitigations such as a Content Security Policy were not enabled.

Patches

This has been patched in 1.3.0

Workarounds

Sanitise any untrusted input before passing it to Leaf and enable a CSP to block inline script and CSS data.

References

https://github.com/vapor/leaf-kit-ghsa-rv3x-xq3r-8j9h/pull/1

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦SwiftURLgithub.com/vapor/leaf-kitall versions1.3.0

Affected Products

1 product · 1 configurations
Application
leafkitvapor
< 1.3.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/vapor/leaf-kit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/vapor/leaf-kit to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rv3x-xq3r-8j9h is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact This affects anyone passing unsanitised data to Leaf's variable tags. Before this fix, Leaf would not escape any strings passed to tags as variables. If an attacker managed to find a variable that was rendered with their unsanitised data, they could inject scripts into a generated Leaf page, which could enable XSS attacks if other mitigations such as a Content Security Policy were not enabled. ### Patches This has been patched in 1.3.0 ### Workarounds Sanitise any untrusted input before passing it to Leaf and enable a CSP to block inline script and CSS data. ### References https:
O3 Security · Impact-Aware SCA

Is GHSA-rv3x-xq3r-8j9h in your dependencies?

Find it across SwiftURL, including transitive dependencies.

LeafKit allows XSS with untrusted user input