NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

jquery-validation vulnerable to Cross-site ScriptingGHSA-rrj2-ph5q-jxw2

MEDIUMFix: jquery-validation/jquery-validation#2462

GHSA-rrj2-ph5q-jxw2 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in jquery-validation. A fix is available for jquery-validation — see the affected versions and patch details below.

Also known asCVE-2025-3573
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs30th percentile — riskier than 30% of all scored CVEsHighest risk
0.00%0.29%0.57%0.86%0.3%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

342other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jquery-validationnpm
382Kdownloads / week

Description

Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmjquery-validationall versions1.20.0npm install jquery-validation@1.20.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jquery-validation, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update jquery-validation to 1.20.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rrj2-ph5q-jxw2 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for GHSA-rrj2-ph5q-jxw2 (CC BY 4.0)

Frequently Asked Questions

Versions of the package jquery-validation before 1.20.0 are vulnerable to Cross-site Scripting (XSS) in the showLabel() function, which may take input from a user-controlled placeholder value. This value will populate a message via $.validator.messages in a user localizable dictionary.
O3 Security · Impact-Aware SCA

Is GHSA-rrj2-ph5q-jxw2 in your dependencies?

Find it across npm, including transitive dependencies.

jquery-validation vulnerable to Cross-site Scripting