NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2021-21252 — jquery-validation

HIGHFix: jquery-validation/jquery-validation@5d8f29e

CVE-2021-21252 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in jquery-validation. A fix is available for jquery-validation — see the affected versions and patch details below.

Regular Expression Denial of Service in jquery-validation

Also known asGHSA-jxwx-85vp-gvwm
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.6%probability of exploitation in next 30 days
Lower Risk+0.14%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.00%1.48%2.96%4.44%0.7%3.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

342other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jquery-validationnpm
141Kdownloads / week

Description

The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmjquery-validationall versions1.19.3npm install jquery-validation@1.19.3
.NETNuGetjQuery.Validationall versions1.19.3dotnet add package jQuery.Validation --version 1.19.3

Affected Products

2 products · 2 configurations
Application
jquery validationjqueryvalidation
< 1.19.3
range
Application
snapcenternetapp
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jquery-validation, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update jquery-validation to 1.19.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21252 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The jQuery Validation Plugin provides drop-in validation for your existing forms. It is published as an npm package "jquery-validation". jquery-validation before version 1.19.3 contains one or more regular expressions that are vulnerable to ReDoS (Regular Expression Denial of Service). This is fixed in 1.19.3.
O3 Security · Impact-Aware SCA

Is CVE-2021-21252 in your dependencies?

Find it across npm, NuGet, including transitive dependencies.

CVE-2021-21252: jquery-validation DoS — Fixed in 1.19.3