Drupal Remote code executionGHSA-rhx9-3qf7-r3j7
HIGHGHSA-rhx9-3qf7-r3j7 is a high-severity (CVSS 8.1) CWE-829 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/drupalReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution. This is mitigated by the default .htaccess protection against PHP execution, and the fact that Composer development dependencies aren't normal installed. You might be vulnerable to this if you are running a version of Drupal before 8.2.2. To be sure you aren't vulnerable, you can remove the <siteroot>/vendor/phpunit directory from your production deployments
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.0&&< 8.2.7 | 8.2.7composer require drupal/core:^8.2.7 |
| 🐘Packagist | drupal/drupal | ≥ 8.0&&< 8.2.7 | 8.2.7composer require drupal/drupal:^8.2.7 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 8.2.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rhx9-3qf7-r3j7 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-rhx9-3qf7-r3j7 in your dependencies?
Find it across Packagist, including transitive dependencies.