NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2017-6381 — core

HIGH

CVE-2017-6381 is a high-severity (CVSS 8.1) CWE-829 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.

Drupal Remote code execution

Also known asGHSA-rhx9-3qf7-r3j7
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
2.81%3.34%3.87%4.40%3.3%3.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘drupal/core🐘drupal/drupal

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution. This is mitigated by the default .htaccess protection against PHP execution, and the fact that Composer development dependencies aren't normal installed. You might be vulnerable to this if you are running a version of Drupal before 8.2.2. To be sure you aren't vulnerable, you can remove the <siteroot>/vendor/phpunit directory from your production deployments

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdrupal/core≥ 8.0&&< 8.2.78.2.7composer require drupal/core:^8.2.7
🐘Packagistdrupal/drupal≥ 8.0&&< 8.2.78.2.7composer require drupal/drupal:^8.2.7

Affected Products

1 product · 60 configurations
Application
drupaldrupal
20 versions
8.0.08.0.18.0.28.0.38.0.48.0.58.0.68.1.08.1.18.1.28.1.38.1.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update drupal/core to 8.2.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-6381 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution. This is mitigated by the default .htaccess protection against PHP execution, and the fact that Composer development dependencies aren't normal installed. You might be vulnerable to this if you are running a version of Drupal before 8.2.2. To be sure you aren't vulnerable, you can remove the <siteroot>/vendor/phpunit directory from your production deployments
O3 Security · Impact-Aware SCA

Is CVE-2017-6381 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-6381: core RCE — Fixed in 8.2.7