CVE-2025-13080 — core
MEDIUMCVE-2025-13080 is a medium-severity (CVSS 5.3) CWE-754 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Drupal core - Moderately critical - Denial of Service - SA-CORE-2025-005
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-13080.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/core🐘drupal/core🐘drupal/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Improper Check for Unusual or Exceptional Conditions vulnerability in Drupal Drupal core allows Forceful Browsing. This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.0.0&&< 10.4.9 | 10.4.9composer require drupal/core:^10.4.9 |
| 🐘Packagist | drupal/core | ≥ 10.5.0&&< 10.5.6 | 10.5.6composer require drupal/core:^10.5.6 |
| 🐘Packagist | drupal/core | ≥ 11.0.0&&< 11.1.9 | 11.1.9composer require drupal/core:^11.1.9 |
| 🐘Packagist | drupal/core | ≥ 11.2.0&&< 11.2.8 | 11.2.8composer require drupal/core:^11.2.8 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 10.4.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-13080 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-13080 in your dependencies?
Find it across Packagist, including transitive dependencies.