NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

Apache Derby: LDAP injection vulnerability in authenticatorGHSA-rcjc-c4pj-xxrp

CRITICAL

GHSA-rcjc-c4pj-xxrp is a critical-severity (CVSS 9.8) CWE-74 vulnerability in org.apache.derby:derby. A fix is available for org.apache.derby:derby — see the affected versions and patch details below.

Also known asCVE-2022-46337
Published
Updated
Affected
16 pkgs
Patched
3 / 16
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-rcjc-c4pj-xxrp.

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs73th percentile — riskier than 73% of all scored CVEsHighest risk
0.00%0.64%1.28%1.92%0.0%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

16 pkgs affected
☕org.apache.derby:derby☕org.apache.derby:derby☕org.apache.derby:derby☕org.apache.derby:derby☕org.apache.derby:derby☕org.apache.derby:derby☕org.apache.derby:derby☕org.apache.derby:derby+8 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A cleverly devised username might bypass LDAP authentication checks. In LDAP-authenticated Derby installations, this could let an attacker fill up the disk by creating junk Derby databases. In LDAP-authenticated Derby installations, this could also allow the attacker to execute malware which was visible to and executable by the account which booted the Derby server. In LDAP-protected databases which weren't also protected by SQL GRANT/REVOKE authorization, this vulnerability could also let an attacker view and corrupt sensitive data and run sensitive database functions and procedures.

Mitigation:

Users should upgrade to Java 21 and Derby 10.17.1.0.

Alternatively, users who wish to remain on older Java versions should build their own Derby distribution from one of the release families to which the fix was backported: 10.16, 10.15, and 10.14. Those are the releases which correspond, respectively, with Java LTS versions 17, 11, and 8.

Affected Packages

16 total 3 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.derby:derby≥ 10.1.1.0No fix
☕Mavenorg.apache.derby:derby≥ 10.2.1.6No fix
☕Mavenorg.apache.derby:derby≥ 10.3.1.4No fix
☕Mavenorg.apache.derby:derby≥ 10.4.1.3No fix
☕Mavenorg.apache.derby:derby≥ 10.5.1.1No fix
☕Mavenorg.apache.derby:derby≥ 10.6.1.0No fix

Affected Products

1 product · 3 configurations
Application
derbyapache
≥ 10.15.1.3 && < 10.15.2.1
1 version
10.16.1.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.derby:derby, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for GHSA-rcjc-c4pj-xxrp; check the affected-versions list above or the advisory for the patched release of org.apache.derby:derby, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

A cleverly devised username might bypass LDAP authentication checks. In LDAP-authenticated Derby installations, this could let an attacker fill up the disk by creating junk Derby databases. In LDAP-authenticated Derby installations, this could also allow the attacker to execute malware which was visible to and executable by the account which booted the Derby server. In LDAP-protected databases which weren't also protected by SQL GRANT/REVOKE authorization, this vulnerability could also let an attacker view and corrupt sensitive data and run sensitive database functions and procedures. Mitigat
O3 Security · Impact-Aware SCA

Is GHSA-rcjc-c4pj-xxrp in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Derby: LDAP injection vulnerability in authenticator