CVE-2015-1832 — derby
CRITICALCVE-2015-1832 is a critical-severity (CVSS 9.1) CWE-399 vulnerability in org.apache.derby:derby. EPSS puts its 30-day exploitation probability at 12.2% (96th percentile). A fix is available for org.apache.derby:derby — see the affected versions and patch details below.
Improper Restriction of XML External Entity Reference in Apace Derby
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.derby:derbyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
XML external entity (XXE) vulnerability in the SqlXmlUtil code in Apache Derby before 10.12.1.1, when a Java Security Manager is not in place, allows context-dependent attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving XmlVTI and the XML datatype.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.derby:derby | all versions | 10.12.1.1org.apache.derby:derby:10.12.1.1 |
Affected Products
derbyapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.derby:derby, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.derby:derby to 10.12.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-1832 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2015-1832 in your dependencies?
Find it across Maven, including transitive dependencies.