CVE-2010-2232 — derby
HIGHCVE-2010-2232 is a high-severity (CVSS 7.5) CWE-284 vulnerability in org.apache.derby:derby. A fix is available for org.apache.derby:derby — see the affected versions and patch details below.
Improper Access Control in Apache Derby
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.derby:derbyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Derby 10.1.2.1, 10.2.2.0, 10.3.1.4, and 10.4.1.3, Export processing may allow an attacker to overwrite an existing file.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.derby:derby | ≥ 10.1.2.1&&< 10.4.2.0 | 10.4.2.0org.apache.derby:derby:10.4.2.0 |
Affected Products
derbyapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.derby:derby, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.derby:derby to 10.4.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-2232 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2010-2232 in your dependencies?
Find it across Maven, including transitive dependencies.