Femanager extension for TYPO3 allows Insecure Direct Object ReferenceGHSA-rc5f-3hfv-jxp2
Fix: in2code-de/femanager@9bd9fbdGHSA-rc5f-3hfv-jxp2 is a CWE-639 vulnerability in in2code/femanager. A fix is available for in2code/femanager — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-rc5f-3hfv-jxp2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
in2code/femanager🐘in2code/femanager🐘in2code/femanagerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The femanager extension for TYPO3 allows Insecure Direct Object Reference resulting in unauthorized modification of userdata. This issue affects femanager version 6.4.1 and below, 7.0.0 to 7.5.2 and 8.0.0 to 8.3.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | in2code/femanager | all versions | 6.4.2composer require in2code/femanager:^6.4.2 |
| 🐘Packagist | in2code/femanager | ≥ 7.0.0&&< 7.5.3 | 7.5.3composer require in2code/femanager:^7.5.3 |
| 🐘Packagist | in2code/femanager | ≥ 8.0.0&&< 8.3.1 | 8.3.1composer require in2code/femanager:^8.3.1 |
Affected Products
typo3typo3Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for in2code/femanager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update in2code/femanager to 6.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-rc5f-3hfv-jxp2 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-rc5f-3hfv-jxp2 in your dependencies?
Find it across Packagist, including transitive dependencies.