CVE-2025-48202 is a medium-severity (CVSS 5.3) CWE-425 vulnerability in in2code/femanager. A fix is available for in2code/femanager — see the affected versions and patch details below.
The femanager TYPO3 extension allows Insecure Direct Object Reference
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-48202.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
in2code/femanager🐘in2code/femanager🐘in2code/femanager🐘in2code/femanagerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Insecure Direct Object Reference (IDOR) in the femanager TYPO3 extension allows attackers to view frontend user data via a user parameter in the newAction of the newController.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | in2code/femanager | ≥ 8.0.0&&< 8.2.2 | 8.2.2composer require in2code/femanager:^8.2.2 |
| 🐘Packagist | in2code/femanager | ≥ 7.0.0&&< 7.4.2 | 7.4.2composer require in2code/femanager:^7.4.2 |
| 🐘Packagist | in2code/femanager | ≥ 6.0.0&&< 6.4.1 | 6.4.1composer require in2code/femanager:^6.4.1 |
| 🐘Packagist | in2code/femanager | ≥ 5.5.0&&< 5.5.5 | 5.5.5composer require in2code/femanager:^5.5.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for in2code/femanager, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update in2code/femanager to 8.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-48202 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-48202 in your dependencies?
Find it across Packagist, including transitive dependencies.