mangadex-downloader vulnerable to unauthorized file readingGHSA-r9x7-2xmr-v8fw
MEDIUMFix: mansuf/mangadex-downloader@439cc28GHSA-r9x7-2xmr-v8fw is a medium-severity (CVSS 5.3) Improper Input Validation vulnerability in mangadex-downloader. A fix is available for mangadex-downloader — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-r9x7-2xmr-v8fw.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mangadex-downloaderReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When using file:<location> command and <location> is web URL location (http, https). mangadex-downloader will try to open and read a file in local disk if the content from online file is exist-as-a-file in victim computer
So far, the app only read the files and not execute it. But still, when someone reading your files without you knowing, it's very scary.
Proof of Concept (PoC)
https://www.mansuf.link/unauthorized-file-read-in-mangadex-downloader-cve-2022-36082/
Workarounds
Unfortunately, there is no workarounds to make it safe from this issue. But i suggest you double check the url before proceed to download or update to latest version ( >= 1.7.2)
Patches
Fixed in version 1.7.2. Commit patch: https://github.com/mansuf/mangadex-downloader/commit/439cc2825198ebc12b3310c95c39a8c7710c9b42
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | mangadex-downloader | ≥ 1.3.0&&< 1.7.2 | 1.7.2pip install --upgrade 'mangadex-downloader==1.7.2' |
Affected Products
mangadex-downloadermangadex-downloader_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mangadex-downloader, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mangadex-downloader to 1.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r9x7-2xmr-v8fw is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-r9x7-2xmr-v8fw in your dependencies?
Find it across PyPI, including transitive dependencies.