EC-CUBE Cross-site scripting vulnerabilityGHSA-r6qq-qc9m-98w2
MEDIUMGHSA-r6qq-qc9m-98w2 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ec-cube/ec-cube. A fix is available for ec-cube/ec-cube — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
ec-cube/ec-cubeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting vulnerability in EC-CUBE EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | ec-cube/ec-cube | ≥ 4.0.0&&< 4.0.6 | 4.0.6composer require ec-cube/ec-cube:^4.0.6 |
Affected Products
ec-cubeec-cubeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ec-cube/ec-cube, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update ec-cube/ec-cube to 4.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r6qq-qc9m-98w2 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-r6qq-qc9m-98w2 in your dependencies?
Find it across Packagist, including transitive dependencies.