NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2020-5590 — ec-cube

HIGH

CVE-2020-5590 is a high-severity (CVSS 8.1) Path Traversal vulnerability in ec-cube/ec-cube. A fix is available for ec-cube/ec-cube — see the affected versions and patch details below.

EC-CUBE Directory traversal vulnerability

Also known asGHSA-hx79-x87c-hgm3
Published
Updated
Affected
2 pkgs
Patched
1 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
1.56%1.94%2.33%2.71%2.2%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘ec-cube/ec-cube🐘ec-cube/ec-cube

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Directory traversal vulnerability in EC-CUBE 3.0.0 to 3.0.18 and 4.0.0 to 4.0.3 allows remote authenticated attackers to delete arbitrary files and/or directories on the server via unspecified vectors.

Affected Packages

2 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistec-cube/ec-cube≥ 3.0.0No fix
🐘Packagistec-cube/ec-cube≥ 4.0.0&&< 4.0.44.0.4composer require ec-cube/ec-cube:^4.0.4

Affected Products

1 product · 2 configurations
Application
ec-cubeec-cube
≥ 4.0.0 && ≤ 4.0.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ec-cube/ec-cube, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2020-5590; check the affected-versions list above or the advisory for the patched release of ec-cube/ec-cube, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Directory traversal vulnerability in EC-CUBE 3.0.0 to 3.0.18 and 4.0.0 to 4.0.3 allows remote authenticated attackers to delete arbitrary files and/or directories on the server via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2020-5590 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-5590: ec-cube Path Traversal — Fixed in 4.0.4