NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-20751 — ec-cube

MEDIUM

CVE-2021-20751 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in ec-cube/ec-cube. A fix is available for ec-cube/ec-cube — see the affected versions and patch details below.

EC-CUBE Cross-site scripting vulnerability

Also known asGHSA-r6qq-qc9m-98w2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.09%0.59%1.09%1.59%0.6%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘ec-cube/ec-cube

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting vulnerability in EC-CUBE EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistec-cube/ec-cube≥ 4.0.0&&< 4.0.64.0.6composer require ec-cube/ec-cube:^4.0.6

Affected Products

1 product · 2 configurations
Application
ec-cubeec-cube
≥ 4.0.0 && < 4.0.5
1 version
4.0.5.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ec-cube/ec-cube, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ec-cube/ec-cube to 4.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-20751 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting vulnerability in EC-CUBE EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.
O3 Security · Impact-Aware SCA

Is CVE-2021-20751 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-20751: ec-cube XSS — Fixed in 4.0.6