Information Exposure vulnerability in Eclipse JettyGHSA-r28m-g6j9-r2h5
MEDIUMGHSA-r28m-g6j9-r2h5 is a medium-severity (CVSS 5.3) CWE-213 vulnerability in org.eclipse.jetty:jetty-server. A fix is available for org.eclipse.jetty:jetty-server — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-server☕org.eclipse.jetty:jetty-serverReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Eclipse Jetty version 9.2.27, 9.3.26, and 9.4.16, the server running on Windows is vulnerable to exposure of the fully qualified Base Resource directory name on Windows to a remote client when it is configured for showing a Listing of directory contents. This information reveal is restricted to only the content in the configured base resource directories.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 9.2.0&&< 9.2.28.v20190418 | 9.2.28.v20190418org.eclipse.jetty:jetty-server:9.2.28.v20190418 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 9.3.0&&< 9.3.27.v20190418 | 9.3.27.v20190418org.eclipse.jetty:jetty-server:9.3.27.v20190418 |
| ☕Maven | org.eclipse.jetty:jetty-server | ≥ 9.4.0&&< 9.4.17.v20190418 | 9.4.17.v20190418org.eclipse.jetty:jetty-server:9.4.17.v20190418 |
Affected Products
jettyeclipseelementnetapponcommand system managernetappsnap creator frameworknetappsnapcenternetappsnapmanagernetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-server to 9.2.28.v20190418 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-r28m-g6j9-r2h5 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is GHSA-r28m-g6j9-r2h5 in your dependencies?
Find it across Maven, including transitive dependencies.