NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

phpMyAdmin DoS VulnerabilityGHSA-qf3f-7x69-qfv3

MEDIUM

GHSA-qf3f-7x69-qfv3 is a medium-severity (CVSS 5.9) CWE-399 vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

Also known asCVE-2016-6622
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.44%1.06%1.68%2.30%1.0%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in phpMyAdmin. An unauthenticated user is able to execute a denial-of-service (DoS) attack by forcing persistent connections when phpMyAdmin is running with $cfg['AllowArbitraryServer']=true. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.6&&< 4.6.44.6.4composer require phpmyadmin/phpmyadmin:^4.6.4
🐘Packagistphpmyadmin/phpmyadmin≥ 4.4&&< 4.4.15.84.4.15.8composer require phpmyadmin/phpmyadmin:^4.4.15.8
🐘Packagistphpmyadmin/phpmyadmin≥ 4.0&&< 4.0.10.174.0.10.17composer require phpmyadmin/phpmyadmin:^4.0.10.17

Affected Products

1 product · 60 configurations
Application
phpmyadminphpmyadmin
60 versions
4.0.04.0.14.0.24.0.34.0.44.0.4.14.0.4.24.0.54.0.64.0.74.0.84.0.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qf3f-7x69-qfv3 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

An issue was discovered in phpMyAdmin. An unauthenticated user is able to execute a denial-of-service (DoS) attack by forcing persistent connections when phpMyAdmin is running with `$cfg['AllowArbitraryServer']=true`. All 4.6.x versions (prior to 4.6.4), 4.4.x versions (prior to 4.4.15.8), and 4.0.x versions (prior to 4.0.10.17) are affected.
O3 Security · Impact-Aware SCA

Is GHSA-qf3f-7x69-qfv3 in your dependencies?

Find it across Packagist, including transitive dependencies.

phpMyAdmin DoS Vulnerability (Medium 5.9)