Apache Archiva vulnerable to privilege escalation via stored cross-site scripting (XSS)GHSA-qf34-f43r-gv9p
MEDIUMFix: apache/archiva@d62e81cGHSA-qf34-f43r-gv9p is a medium-severity (CVSS 6.5) Cross-site Scripting (XSS) vulnerability in org.apache.archiva:archiva. A fix is available for org.apache.archiva:archiva — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-qf34-f43r-gv9p.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.archiva:archivaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Archiva is vulnerable to privilege escalation vua stored cross-site-scripting using the file upload service to upload malicious content. The issue can be exploited only by authenticated users which can create directory name to inject some XSS content and gain some privileges, such as an admin user.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.archiva:archiva | ≥ 2.0.0&&< 2.2.10 | 2.2.10org.apache.archiva:archiva:2.2.10 |
Affected Products
archivaapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.archiva:archiva, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.archiva:archiva to 2.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-qf34-f43r-gv9p is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-qf34-f43r-gv9p in your dependencies?
Find it across Maven, including transitive dependencies.