CVE-2011-0533 — archiva
CVE-2011-0533 is a Cross-site Scripting (XSS) vulnerability in org.apache.archiva:archiva. A fix is available for org.apache.archiva:archiva — see the affected versions and patch details below.
Apache Continuum and Archiva vulnerable to Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.archiva:archiva☕org.apache.continuum:continuum☕org.apache.continuum:continuumReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in Apache Continuum 1.1 through 1.2.3.1, 1.3.6, and 1.4.0 Beta; and Archiva 1.3.0 through 1.3.3 and 1.0 through 1.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted parameter, related to the autoIncludeParameters setting for the extremecomponents table.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.archiva:archiva | ≥ 1.0&&< 1.3.4 | 1.3.4org.apache.archiva:archiva:1.3.4 |
| ☕Maven | org.apache.continuum:continuum | ≥ 1.1&&< 1.3.7 | 1.3.7org.apache.continuum:continuum:1.3.7 |
| ☕Maven | org.apache.continuum:continuum | all versions | No fix |
Affected Products
archivaapachecontinuumapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.archiva:archiva, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.archiva:archiva to 1.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2011-0533 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2011-0533 in your dependencies?
Find it across Maven, including transitive dependencies.