CVE-2010-4408 — archiva
CVE-2010-4408 is a Cross-site Scripting (XSS) vulnerability in org.apache.archiva:archiva. A fix is available for org.apache.archiva:archiva — see the affected versions and patch details below.
Apache Archiva does not require entry of the administrator's password at the time of modifying a user account
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.archiva:archivaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Archiva 1.0 through 1.0.3, 1.1 through 1.1.4, 1.2 through 1.2.2, and 1.3 through 1.3.1 does not require entry of the administrator's password at the time of modifying a user account, which makes it easier for context-dependent attackers to gain privileges by leveraging a (1) unattended workstation or (2) cross-site request forgery (CSRF) vulnerability, a related issue to CVE-2010-3449.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.archiva:archiva | ≥ 1.0&&< 1.3.2 | 1.3.2org.apache.archiva:archiva:1.3.2 |
Affected Products
archivaapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.archiva:archiva, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.archiva:archiva to 1.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2010-4408 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2010-4408 in your dependencies?
Find it across Maven, including transitive dependencies.