Kubernetes privilege escalation vulnerabilityGHSA-q78c-gwqw-jcmc
HIGHFix: kubernetes/kubernetes#120128GHSA-q78c-gwqw-jcmc is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in k8s.io/kubernetes. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for k8s.io/kubernetes — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-q78c-gwqw-jcmc.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
k8s.io/kubernetes🐹k8s.io/kubernetes🐹k8s.io/kubernetes🐹k8s.io/kubernetes🐹k8s.io/kubernetesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A security issue was discovered in Kubernetes where a user that can create pods on Windows nodes may be able to escalate to admin privileges on those nodes. Kubernetes clusters are only affected if they include Windows nodes.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | k8s.io/kubernetes | ≥ 1.28.0&&< 1.28.1 | 1.28.1go get k8s.io/kubernetes@v1.28.1 |
| 🐹Go | k8s.io/kubernetes | ≥ 1.27.0&&< 1.27.5 | 1.27.5go get k8s.io/kubernetes@v1.27.5 |
| 🐹Go | k8s.io/kubernetes | ≥ 1.26.0&&< 1.26.8 | 1.26.8go get k8s.io/kubernetes@v1.26.8 |
| 🐹Go | k8s.io/kubernetes | ≥ 1.25.0&&< 1.25.13 | 1.25.13go get k8s.io/kubernetes@v1.25.13 |
| 🐹Go | k8s.io/kubernetes | all versions | 1.24.17go get k8s.io/kubernetes@v1.24.17 |
Affected Products
kuberneteskubernetesResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for k8s.io/kubernetes, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update k8s.io/kubernetes to 1.28.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q78c-gwqw-jcmc is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Kubernetes clusters are only affected if they include Windows nodes. Any Kubernetes environment with Windows nodes is impacted. Run kubectl get nodes -l kubernetes.io/os=windows to see if any Windows nodes are in use.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 4.10 | openshift4-wincw/windows-machine-config-rhel8-operator:5.1.2-3 | RHSA-2023:4835 |
| Red Hat OpenShift Container Platform 4.11 | openshift4-wincw/windows-machine-config-rhel8-operator:6.0.2-5 | RHSA-2023:4780 |
| Red Hat OpenShift Container Platform 4.12 | openshift4-wincw/windows-machine-config-rhel8-operator:7.1.1-9 | RHSA-2023:4777 |
| Red Hat OpenShift Container Platform 4.13 | openshift4-wincw/windows-machine-config-rhel9-operator:8.0.2-9 | RHSA-2023:4885 |
| Red Hat OpenShift Container Platform 4.14 | openshift4-wincw/windows-machine-config-operator-bundle:v9.0.0-104 | RHSA-2023:7515 |
Frequently Asked Questions
Is GHSA-q78c-gwqw-jcmc in your dependencies?
Find it across Go, including transitive dependencies.