NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2024-9042 — kubernetes

MEDIUMFix: kubernetes/kubernetes@45f4ccc

CVE-2024-9042 is a medium-severity (CVSS 5.9) Improper Input Validation vulnerability in k8s.io/kubernetes. A fix is available for k8s.io/kubernetes — see the affected versions and patch details below.

Kubernetes allows Command Injection affecting Windows nodes via nodes/*/logs/query API

Also known asGHSA-vv39-3w5q-974qGO-2025-3522
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-9042.

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.63%1.27%1.90%0.3%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹k8s.io/kubernetes🐹k8s.io/kubernetes🐹k8s.io/kubernetes🐹k8s.io/kubernetes

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

A security vulnerability has been discovered in Kubernetes windows nodes that could allow a user with the ability to query a node's '/logs' endpoint to execute arbitrary commands on the host. This CVE affects only Windows worker nodes. Your worker node is vulnerable to this issue if it is running one of the affected versions listed below.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gok8s.io/kubernetesall versions1.29.13go get k8s.io/kubernetes@v1.29.13
🐹Gok8s.io/kubernetes≥ 1.30.0-alpha.0&&< 1.30.91.30.9go get k8s.io/kubernetes@v1.30.9
🐹Gok8s.io/kubernetes≥ 1.31.0-alpha.0&&< 1.31.51.31.5go get k8s.io/kubernetes@v1.31.5
🐹Gok8s.io/kubernetes≥ 1.32.0-alpha.0&&< 1.32.11.32.1go get k8s.io/kubernetes@v1.32.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for k8s.io/kubernetes, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update k8s.io/kubernetes to 1.29.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-9042 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This CVE affects only Windows worker nodes. To detect whether this vulnerability has been exploited, you can examine your cluster's audit logs to search for node 'logs' queries with suspicious inputs.

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Source: Red Hat security advisory for CVE-2024-9042 (CC BY 4.0)
ProductFixed inAdvisory
OpenShift Windows Machine Config Operator 10.16openshift4-wincw/windows-machine-config-rhel9-operator:v10.16.2-1749241361RHSA-2025:9136
OpenShift Windows Machine Config Operator 10.17openshift4-wincw/windows-machine-config-rhel9-operator:9.6-1748967421RHSA-2025:8704

Frequently Asked Questions

A security vulnerability has been discovered in Kubernetes windows nodes that could allow a user with the ability to query a node's '/logs' endpoint to execute arbitrary commands on the host. This CVE affects only Windows worker nodes. Your worker node is vulnerable to this issue if it is running one of the affected versions listed below.
O3 Security · Impact-Aware SCA

Is CVE-2024-9042 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2024-9042: kubernetes — Fixed in 1.29.13