CVE-2025-5187 is a medium-severity (CVSS 6.7) CWE-863 vulnerability in k8s.io/kubernetes. A fix is available for k8s.io/kubernetes — see the affected versions and patch details below.
Nodes can delete themselves by adding an OwnerReference
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-5187.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
k8s.io/kubernetes🐹k8s.io/kubernetes🐹k8s.io/kubernetesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability exists in the NodeRestriction admission controller in Kubernetes clusters where node users can delete their corresponding node object by patching themselves with an OwnerReference to a cluster-scoped resource. If the OwnerReference resource does not exist or is subsequently deleted, the given node object will be deleted via garbage collection.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | k8s.io/kubernetes | all versions | 1.31.12go get k8s.io/kubernetes@v1.31.12 |
| 🐹Go | k8s.io/kubernetes | ≥ 1.32.0-alpha.0&&< 1.32.8 | 1.32.8go get k8s.io/kubernetes@v1.32.8 |
| 🐹Go | k8s.io/kubernetes | ≥ 1.33.0-alpha.0&&< 1.33.4 | 1.33.4go get k8s.io/kubernetes@v1.33.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for k8s.io/kubernetes, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update k8s.io/kubernetes to 1.31.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-5187 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is rated as having a Moderate severity. For a successful attack to take place, the attacker needs to have a high privileged account with enough privileges to create the nodes.
This vulnerability can be mitigated by enabling the OwnerReferencesPermissionEnforcement admission controller, which will prevent any user without delete permissions on an object from modifying the OwnerReferences on that object. Note that this admission controller will apply to all users and object types.Source: Red Hat security advisory for CVE-2025-5187 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift Container Platform 4.18 | openshift4/ose-cluster-kube-apiserver-rhel9-operator:ose-cluster-kube-apiserver-operator-container-v4.18.0-202509100344.p2.gb6ad4b0.assembly.stream.el9 | RHBA-2025:15714 |
| Red Hat OpenShift Container Platform 4.19 | openshift4/ose-cluster-kube-apiserver-rhel9-operator:ose-cluster-kube-apiserver-operator-container-v4.19.0-202509091807.p2.g80c1fc3.assembly.stream.el9 | RHBA-2025:15694 |
Frequently Asked Questions
Is CVE-2025-5187 in your dependencies?
Find it across Go, including transitive dependencies.