Werkzeug possible resource exhaustion when parsing file data in formsGHSA-q34m-jh98-gwm2
HIGHFix: pallets/quart@5e78c41GHSA-q34m-jh98-gwm2 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in werkzeug. A fix is available for werkzeug — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-q34m-jh98-gwm2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
werkzeug🐍quartReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Werkzeug is a Web Server Gateway Interface web application library. Applications using werkzeug.formparser.MultiPartParser corresponding to a version of Werkzeug prior to 3.0.6 to parse multipart/form-data requests (e.g. all flask applications) are vulnerable to a relatively simple but effective resource exhaustion (denial of service) attack. A specifically crafted form submission request can cause the parser to allocate and block 3 to 8 times the upload size in main memory. There is no upper limit; a single upload at 1 Gbit/s can exhaust 32 GB of RAM in less than 60 seconds. Werkzeug version 3.0.6 fixes this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | werkzeug | ≥ 2.0.0rc1&&< 3.0.6 | 3.0.6pip install --upgrade 'werkzeug==3.0.6' |
| 🐍PyPI | quart | all versions | 0.20.0pip install --upgrade 'quart==0.20.0' |
Affected Products
quartpalletsprojectswerkzeugpalletsprojectsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for werkzeug, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update werkzeug to 3.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-q34m-jh98-gwm2 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The Request.max_content_length setting and resource limits provided by deployment software and platforms are available to limit the resources used during a request. This vulnerability does not affect those settings. All three types of limits should be considered and set appropriately when deploying an application.Source: Red Hat security advisory for GHSA-q34m-jh98-gwm2 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenShift AI 2.16 | rhoai/odh-modelmesh-runtime-adapter-rhel8:v2.16.0-1732953768 | RHSA-2024:10852 |
| Red Hat OpenShift AI 2.17 | rhoai/odh-modelmesh-runtime-adapter-rhel8:v2.17.0-1739102748 | RHSA-2025:1448 |
Frequently Asked Questions
Is GHSA-q34m-jh98-gwm2 in your dependencies?
Find it across PyPI, including transitive dependencies.