CVE-2019-14322 — werkzeug
HIGHCVE-2019-14322 is a high-severity (CVSS 7.5) Path Traversal vulnerability in werkzeug. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for werkzeug — see the affected versions and patch details below.
Pallets Werkzeug vulnerable to Path Traversal
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
werkzeugReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In Pallets Werkzeug before 0.15.5, SharedDataMiddleware mishandles drive names (such as C:) in Windows pathnames.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | werkzeug | all versions | 0.15.5pip install --upgrade 'werkzeug==0.15.5' |
Affected Products
werkzeugpalletsprojectsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Pallets Werkzeug 0.15.4 - Path Traversal
by faisalfs10x · Jul 6, 2021
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for werkzeug, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update werkzeug to 0.15.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-14322 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
How to detect CVE-2019-14322
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2019-14322 -u https://target- Template
- Pallets Werkzeug <0.15.5 - Local File Inclusion
- Severity
- high
- Impact
- The LFI vulnerability can lead to unauthorized access to sensitive files, potential data leakage, and remote code execution.
- Remediation
- Upgrade Pallets Werkzeug to version 0.15.5 or above to mitigate the LFI vulnerability.
Template by ProjectDiscovery nuclei-templates (madrobot), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2019-14322 in your dependencies?
Find it across PyPI, including transitive dependencies.