NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

phpMyAdmin XSS VulnerabilityGHSA-pw34-qf6c-84fc

MEDIUMFix: phpmyadmin/phpmyadmin@75a5582

GHSA-pw34-qf6c-84fc is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.

Also known asCVE-2016-2040
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.71%1.43%2.14%0.5%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) table name, (2) SET value, (3) search query, or (4) hostname in a Location header.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphpmyadmin/phpmyadmin≥ 4.0&&< 4.0.10.134.0.10.13composer require phpmyadmin/phpmyadmin:^4.0.10.13
🐘Packagistphpmyadmin/phpmyadmin≥ 4.4&&< 4.4.15.34.4.15.3composer require phpmyadmin/phpmyadmin:^4.4.15.3
🐘Packagistphpmyadmin/phpmyadmin≥ 4.5&&< 4.5.44.5.4composer require phpmyadmin/phpmyadmin:^4.5.4

Affected Products

4 products · 50 configurations
OS
fedorafedoraproject
2 versions
2223
OS
leapopensuse
1 version
42.1
OS
opensuseopensuse
2 versions
13.113.2
Application
phpmyadminphpmyadmin
43 versions
4.0.04.0.14.0.104.0.10.14.0.10.24.0.10.34.0.10.44.0.10.54.0.10.64.0.10.74.0.10.84.0.10.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phpmyadmin/phpmyadmin to 4.0.10.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pw34-qf6c-84fc is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 allow remote authenticated users to inject arbitrary web script or HTML via a (1) table name, (2) SET value, (3) search query, or (4) hostname in a Location header.
O3 Security · Impact-Aware SCA

Is GHSA-pw34-qf6c-84fc in your dependencies?

Find it across Packagist, including transitive dependencies.

phpMyAdmin XSS Vulnerability (Medium 5.4)