NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Exposure of Sensitive Information to an Unauthorized Actor in follow-redirectsGHSA-pw2r-vq6v-hr8c

MEDIUMFix: follow-redirects/follow-redirects@62e546a

GHSA-pw2r-vq6v-hr8c is a medium-severity (CVSS 5.9) CWE-212 vulnerability in follow-redirects. A fix is available for follow-redirects — see the affected versions and patch details below.

Also known asCVE-2022-0536
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.22%1.84%0.1%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
follow-redirectsnpm
143.4Mdownloads / week

Description

Improper Removal of Sensitive Information Before Storage or Transfer in NPM follow-redirects prior to 1.14.8.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmfollow-redirectsall versions1.14.8npm install follow-redirects@1.14.8

Affected Products

1 product · 1 configurations
Application
follow-redirectsfollow-redirects_project
< 1.14.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for follow-redirects, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update follow-redirects to 1.14.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pw2r-vq6v-hr8c is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OpenShift Service Mesh 2.1openshift-service-mesh/kiali-rhel8:1.36.9-1RHSA-2022:1739
Red Hat Migration Toolkit for Containers 1.7rhmtc/openshift-migration-ui-rhel8:v1.7.2-9RHSA-2022:5483
Red Hat OpenShift Data Foundation 4.11 on RHEL8odf4/odf-console-rhel8:v4.11.0-51RHSA-2022:6156
RHINT Service Registry 2.3.0 GAfollow-redirectsRHSA-2022:6835
Red Hat Openshift Data Foundation 4.14odf4/cephcsi-rhel9:v4.14-1764178221RHSA-2025:22420
Red Hat Openshift Data Foundation 4.15odf4/cephcsi-rhel9:v4.15-1764176261RHSA-2025:22418
Red Hat Openshift Data Foundation 4.16odf4/cephcsi-rhel9:v4.16-1764168955RHSA-2025:22416
Red Hat Openshift Data Foundation 4.17odf4/cephcsi-rhel9:v4.17-1764167834RHSA-2025:22415

Frequently Asked Questions

Exposure of Sensitive Information to an Unauthorized Actor in NPM follow-redirects prior to 1.14.8.
O3 Security · Impact-Aware SCA

Is GHSA-pw2r-vq6v-hr8c in your dependencies?

Find it across npm, including transitive dependencies.

Exposure of Sensitive Information to an Unauthorized…