NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-0155 — follow-redirects

HIGHFix: follow-redirects/follow-redirects@8b347cb

CVE-2022-0155 is a high-severity (CVSS 8) CWE-359 vulnerability in follow-redirects. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for follow-redirects — see the affected versions and patch details below.

Exposure of Private Personal Information to an Unauthorized Actor in follow-redirects/follow-redirects

Also known asGHSA-74fj-2j2h-c42q
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.80%1.51%2.22%2.93%1.3%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
follow-redirectsnpm
142.9Mdownloads / week

Description

follow-redirects is vulnerable to Exposure of Private Personal Information to an Unauthorized Actor

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmfollow-redirectsall versions1.14.7npm install follow-redirects@1.14.7

Affected Products

2 products · 4 configurations
Application
follow-redirectsfollow-redirects_project
< 1.14.7
range
Application
sinec inssiemens
< 1.0
1 version
1.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for follow-redirects, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update follow-redirects to 1.14.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0155 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Virtualization Engine 4.4ovirt-web-ui-0:1.9.2-1.el8evRHSA-2022:8502
Red Hat Openshift Data Foundation 4.14odf4/cephcsi-rhel9:v4.14-1764178221RHSA-2025:22420
Red Hat Openshift Data Foundation 4.15odf4/cephcsi-rhel9:v4.15-1764176261RHSA-2025:22418
Red Hat Openshift Data Foundation 4.16odf4/cephcsi-rhel9:v4.16-1764168955RHSA-2025:22416
Red Hat Openshift Data Foundation 4.17odf4/cephcsi-rhel9:v4.17-1764167834RHSA-2025:22415
Red Hat Openshift Data Foundation 4.18odf4/cephcsi-rhel9:v4.18-1761854289RHSA-2025:21368
Red Hat Openshift Data Foundation 4.19odf4/cephcsi-rhel9:v4.19-1761844221RHSA-2025:21378
Red Hat Openshift Data Foundation 4.20odf4/cephcsi-rhel9:v4.20-1761848902RHSA-2025:21704

Frequently Asked Questions

follow-redirects is vulnerable to Exposure of Private Personal Information to an Unauthorized Actor
O3 Security · Impact-Aware SCA

Is CVE-2022-0155 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-0155: follow-redirects — Fixed in 1.14.7