NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

Lancet vulnerable to path traversal when unzipping filesGHSA-pp3f-xrw5-q5j4

HIGHFix: duke-git/lancet@f133b32

GHSA-pp3f-xrw5-q5j4 is a high-severity (CVSS 8.8) Path Traversal vulnerability in github.com/duke-git/lancet/v2. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/duke-git/lancet/v2 — see the affected versions and patch details below.

Also known asCVE-2022-41920GO-2022-1114
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-pp3f-xrw5-q5j4.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.29%0.65%1.01%1.37%0.8%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/duke-git/lancet/v2🐹github.com/duke-git/lancet

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

What kind of vulnerability is it? Who is impacted?

ZipSlip issue when use fileutil package to unzip files.

Patches

Has the problem been patched? What versions should users upgrade to?

It will fixed in v2.1.10, Please upgrade version to v2.1.10 or above. Users who use v1.x.x should upgrade v1.3.4 or above.

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

No, users have to upgrade version.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/duke-git/lancet/v2≥ 2.0.0&&< 2.1.102.1.10go get github.com/duke-git/lancet/v2@v2.1.10
🐹Gogithub.com/duke-git/lancetall versions1.3.4go get github.com/duke-git/lancet@v1.3.4

Affected Products

1 product · 2 configurations
Application
lancetlancet_project
≥ 2.0.0 && < 2.1.10
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/duke-git/lancet/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/duke-git/lancet/v2 to 2.1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pp3f-xrw5-q5j4 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

### Impact _What kind of vulnerability is it? Who is impacted?_ ZipSlip issue when use fileutil package to unzip files. ### Patches _Has the problem been patched? What versions should users upgrade to?_ It will fixed in v2.1.10, Please upgrade version to v2.1.10 or above. Users who use v1.x.x should upgrade v1.3.4 or above. ### Workarounds _Is there a way for users to fix or remediate the vulnerability without upgrading?_ No, users have to upgrade version.
O3 Security · Impact-Aware SCA

Is GHSA-pp3f-xrw5-q5j4 in your dependencies?

Find it across Go, including transitive dependencies.

Lancet vulnerable to path traversal when unzipping files