CVE-2022-41920 is a medium-severity (CVSS 6.3) Path Traversal vulnerability in github.com/duke-git/lancet/v2. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/duke-git/lancet/v2 — see the affected versions and patch details below.
Zip slip in Lancet
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-41920.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/duke-git/lancet/v2🐹github.com/duke-git/lancetReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
What kind of vulnerability is it? Who is impacted?
ZipSlip issue when use fileutil package to unzip files.
Patches
Has the problem been patched? What versions should users upgrade to?
It will fixed in v2.1.10, Please upgrade version to v2.1.10 or above. Users who use v1.x.x should upgrade v1.3.4 or above.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
No, users have to upgrade version.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/duke-git/lancet/v2 | ≥ 2.0.0&&< 2.1.10 | 2.1.10go get github.com/duke-git/lancet/v2@v2.1.10 |
| 🐹Go | github.com/duke-git/lancet | all versions | 1.3.4go get github.com/duke-git/lancet@v1.3.4 |
Affected Products
lancetlancet_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/duke-git/lancet/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/duke-git/lancet/v2 to 2.1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-41920 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2022-41920 in your dependencies?
Find it across Go, including transitive dependencies.