GHSA-pj7m-g53m-7638 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars:bootstrap. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.webjars:bootstrap — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
bootstrapnpmDescription
In Bootstrap 4.x before 4.1.2, XSS is possible in the data-target property of scrollspy. This is similar to CVE-2018-14042.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.webjars:bootstrap | ≥ 4.0.0&&< 4.1.2 | 4.1.2org.webjars:bootstrap:4.1.2 |
| 📦npm | bootstrap | ≥ 4.0.0&&< 4.1.2 | 4.1.2npm install bootstrap@4.1.2 |
| .NETNuGet | bootstrap | ≥ 4.0.0&&< 4.1.2 | 4.1.2dotnet add package bootstrap --version 4.1.2 |
| .NETNuGet | bootstrap.sass | ≥ 4.0.0&&< 4.1.2 | 4.1.2dotnet add package bootstrap.sass --version 4.1.2 |
| 🐘Packagist | typo3/cms-core | ≥ 8.0.0&&< 8.7.23 | 8.7.23composer require typo3/cms-core:^8.7.23 |
| 🐘Packagist | typo3/cms-core | ≥ 9.0.0&&< 9.5.4 | 9.5.4composer require typo3/cms-core:^9.5.4 |
Affected Products
bootstrapgetbootstrapResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars:bootstrap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.webjars:bootstrap to 4.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pj7m-g53m-7638 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss Enterprise Application Platform 7.4.9 | org.jboss.hal/hal-console:3.3.16.Final-redhat-00001 | RHSA-2023:0556 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8 | eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el8eap | RHSA-2023:0553 |
| Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9 | eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el9eap | RHSA-2023:0554 |
| Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7 | eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el7eap | RHSA-2023:0552 |
| Red Hat Single Sign-On 7.3.2 zip | bootstrap | RHSA-2019:1456 |
Frequently Asked Questions
Is GHSA-pj7m-g53m-7638 in your dependencies?
Find it across Maven, npm, NuGet, including transitive dependencies.