NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm.NET NuGet🐘 Packagist💎 RubyGems
Not in CISA KEV
MEDIUM severity

CVE-2019-8331 — bootstrap

MEDIUMFix: twbs/bootstrap#28236

CVE-2019-8331 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars:bootstrap. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.webjars:bootstrap — see the affected versions and patch details below.

Bootstrap Vulnerable to Cross-Site Scripting

Also known asGHSA-9v3m-8fp8-mj99
Published
Updated
Affected
14 pkgs
Patched
14 / 14
Exploits
4 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
16.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.00%7.14%14.3%21.4%1.7%16.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

14 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

15Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
bootstrapnpm
8.2Mdownloads / week

Description

Versions of bootstrap prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The data-template attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript.

Recommendation

For bootstrap 4.x upgrade to 4.3.1 or later. For bootstrap 3.x upgrade to 3.4.1 or later.

Affected Packages

14 total 14 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars:bootstrap≥ 3.0.0&&< 3.4.13.4.1org.webjars:bootstrap:3.4.1
☕Mavenorg.webjars:bootstrap≥ 4.0.0&&< 4.3.14.3.1org.webjars:bootstrap:4.3.1
📦npmbootstrap≥ 4.0.0&&< 4.3.14.3.1npm install bootstrap@4.3.1
📦npmbootstrap≥ 3.0.0&&< 3.4.13.4.1npm install bootstrap@3.4.1
📦npmbootstrap-sass≥ 3.0.0&&< 3.4.13.4.1npm install bootstrap-sass@3.4.1
.NETNuGetBootstrap.Less≥ 3.0.0&&< 3.4.13.4.1dotnet add package Bootstrap.Less --version 3.4.1

Affected Products

16 products · 56 configurations
Application
big-ip access policy managerf5
≥ 15.0.0 && < 15.1.0
range
Application
big-ip advanced firewall managerf5
≥ 15.0.0 && < 15.1.0
range
Application
big-ip analyticsf5
≥ 15.0.0 && < 15.1.0
range
Application
big-ip application acceleration managerf5
≥ 15.0.0 && < 15.1.0
range
Application
big-ip application security managerf5
≥ 15.0.0 && < 15.1.0
range
Application
big-ip domain name systemf5
≥ 15.0.0 && < 15.1.0
range
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars:bootstrap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.webjars:bootstrap to 3.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-8331 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat CloudForms 4.6 and newer versions include the vulnerable component, but there is no risk of exploitation since there is no possible vector to access the vulnerability. Older Red Hat CloudForms versions don't use the vulnerable component at all.

ProductFixed inAdvisory
Red Hat Enterprise Linux 7ipa-0:4.6.8-5.el7RHSA-2020:3936
Red Hat Enterprise Linux 8idm:client-8030020200923172426.05ac3f11RHSA-2020:4670
Red Hat Enterprise Linux 8pki-core:10.6-8030020200911215836.5ff1562fRHSA-2020:4847
Red Hat Fuse 7.11.1io.hawt-hawtio-onlineRHSA-2022:8652
Red Hat JBoss Enterprise Application Platform 7.4.9org.jboss.hal/hal-console:3.3.16.Final-redhat-00001RHSA-2023:0556
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 8eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el8eapRHSA-2023:0553
Red Hat JBoss Enterprise Application Platform 7.4 for RHEL 9eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el9eapRHSA-2023:0554
Red Hat JBoss Enterprise Application Platform 7.4 on RHEL 7eap7-hal-console-0:3.3.16-1.Final_redhat_00001.1.el7eapRHSA-2023:0552

Frequently Asked Questions

Versions of `bootstrap` prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The `data-template` attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript. ## Recommendation For `bootstrap` 4.x upgrade to 4.3.1 or later. For `bootstrap` 3.x upgrade to 3.4.1 or later.
O3 Security · Impact-Aware SCA

Is CVE-2019-8331 in your dependencies?

Find it across Maven, npm, NuGet, including transitive dependencies.

CVE-2019-8331: bootstrap XSS — Fixed in 3.4.1