NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm.NET NuGet🐘 Packagist💎 RubyGems
Not in CISA KEV
MEDIUM severity

CVE-2018-20676 — bootstrap

MEDIUMFix: twbs/bootstrap#27047

CVE-2018-20676 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars:bootstrap. A fix is available for org.webjars:bootstrap — see the affected versions and patch details below.

XSS vulnerability that affects bootstrap

Also known asGHSA-3mgp-fx93-9xv5
Published
Updated
Affected
7 pkgs
Patched
7 / 7
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
3.24%4.29%5.34%6.39%5.8%3.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

7 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

15Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
bootstrapnpm
8.2Mdownloads / week
bootstrap-sassnpm
375Kdownloads / week

Description

In Bootstrap before 3.4.0, XSS is possible in the tooltip data-viewport attribute.

Affected Packages

7 total 7 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars:bootstrapall versions3.4.0org.webjars:bootstrap:3.4.0
📦npmbootstrapall versions3.4.0npm install bootstrap@3.4.0
📦npmbootstrap-sassall versions3.4.0npm install bootstrap-sass@3.4.0
.NETNuGetbootstrapall versions3.4.0dotnet add package bootstrap --version 3.4.0
🐘Packagisttwbs/bootstrapall versions3.4.0composer require twbs/bootstrap:^3.4.0
💎RubyGemsbootstrapall versions3.4.0bundle update bootstrap --conservative

Affected Products

1 product · 1 configurations
Application
bootstrapgetbootstrap
< 3.4.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars:bootstrap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.webjars:bootstrap to 3.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-20676 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat CloudForms 4.6 and newer versions include the vulnerable component, but there is no risk of exploitation, since there is no possible vector to access the vulnerability. Older Red Hat CloudForms versions do not use the vulnerable component at all. Red Hat Virtualization 4.2 EUS contains the affected version of…

ProductFixed inAdvisory
Red Hat Decision Manager 7bootstrapRHSA-2020:0133
Red Hat Enterprise Linux 7ipa-0:4.6.8-5.el7RHSA-2020:3936
Red Hat Enterprise Linux 8idm:client-8030020200923172426.05ac3f11RHSA-2020:4670
Red Hat OpenStack Platform 13.0 (Queens)python-XStatic-Bootstrap-SCSS-0:3.4.1.0-1.el7ostRHSA-2020:5571
Red Hat Process Automation 7bootstrapRHSA-2020:0132
Red Hat Single Sign-On 7.3.2 zipbootstrapRHSA-2019:1456
Red Hat Virtualization Engine 4.3ovirt-engine-api-explorer-0:0.0.4-1.el7evRHBA-2019:1076
Red Hat Virtualization Engine 4.3ovirt-engine-api-explorer-0:0.0.5-1.el7evRHBA-2019:1570

Frequently Asked Questions

In Bootstrap before 3.4.0, XSS is possible in the tooltip data-viewport attribute.
O3 Security · Impact-Aware SCA

Is CVE-2018-20676 in your dependencies?

Find it across Maven, npm, NuGet, including transitive dependencies.

CVE-2018-20676: bootstrap XSS — Fixed in 3.4.0