GHSA-3mgp-fx93-9xv5 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.webjars:bootstrap. A fix is available for org.webjars:bootstrap — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
bootstrapnpmbootstrap-sassnpmDescription
In Bootstrap before 3.4.0, XSS is possible in the tooltip data-viewport attribute.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.webjars:bootstrap | all versions | 3.4.0org.webjars:bootstrap:3.4.0 |
| 📦npm | bootstrap | all versions | 3.4.0npm install bootstrap@3.4.0 |
| 📦npm | bootstrap-sass | all versions | 3.4.0npm install bootstrap-sass@3.4.0 |
| .NETNuGet | bootstrap | all versions | 3.4.0dotnet add package bootstrap --version 3.4.0 |
| 🐘Packagist | twbs/bootstrap | all versions | 3.4.0composer require twbs/bootstrap:^3.4.0 |
| 💎RubyGems | bootstrap | all versions | 3.4.0bundle update bootstrap --conservative |
Affected Products
bootstrapgetbootstrapDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars:bootstrap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.webjars:bootstrap to 3.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-3mgp-fx93-9xv5 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat CloudForms 4.6 and newer versions include the vulnerable component, but there is no risk of exploitation, since there is no possible vector to access the vulnerability. Older Red Hat CloudForms versions do not use the vulnerable component at all. Red Hat Virtualization 4.2 EUS contains the affected version of…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Decision Manager 7 | bootstrap | RHSA-2020:0133 |
| Red Hat Enterprise Linux 7 | ipa-0:4.6.8-5.el7 | RHSA-2020:3936 |
| Red Hat Enterprise Linux 8 | idm:client-8030020200923172426.05ac3f11 | RHSA-2020:4670 |
| Red Hat OpenStack Platform 13.0 (Queens) | python-XStatic-Bootstrap-SCSS-0:3.4.1.0-1.el7ost | RHSA-2020:5571 |
| Red Hat Process Automation 7 | bootstrap | RHSA-2020:0132 |
| Red Hat Single Sign-On 7.3.2 zip | bootstrap | RHSA-2019:1456 |
| Red Hat Virtualization Engine 4.3 | ovirt-engine-api-explorer-0:0.0.4-1.el7ev | RHBA-2019:1076 |
| Red Hat Virtualization Engine 4.3 | ovirt-engine-api-explorer-0:0.0.5-1.el7ev | RHBA-2019:1570 |
Frequently Asked Questions
Is GHSA-3mgp-fx93-9xv5 in your dependencies?
Find it across Maven, npm, NuGet, including transitive dependencies.