GHSA-pgww-xf46-h92r is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in lxml. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for lxml — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-pgww-xf46-h92r.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
lxmlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A XSS vulnerability was discovered in python-lxml's clean module. The module's parser didn't properly imitate browsers, which caused different behaviors between the sanitizer and the user's page. A remote attacker could exploit this flaw to run arbitrary HTML/JS code.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | lxml | all versions | 4.6.2pip install --upgrade 'lxml==4.6.2' |
Affected Products
debian linuxdebianfedorafedoraprojectlxmllxmlsnapcenternetappcommunications offline mediation controlleroraclezfs storage appliance kitoracleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lxml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update lxml to 4.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pgww-xf46-h92r is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | python27:2.7-8040020210122160212.cdb2db54 | RHSA-2021:1761 |
| Red Hat Enterprise Linux 8 | python38:3.8-8040020210128125034.b1b639b6 | RHSA-2021:1879 |
| Red Hat Enterprise Linux 8 | python-lxml-0:4.2.3-2.el8 | RHSA-2021:1898 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-python38-babel-0:2.7.0-12.el7 | RHSA-2021:3254 |
Frequently Asked Questions
Is GHSA-pgww-xf46-h92r in your dependencies?
Find it across PyPI, including transitive dependencies.