NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2020-27783 — lxml

MEDIUMFix: lxml/lxml@a105ab8

CVE-2020-27783 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in lxml. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for lxml — see the affected versions and patch details below.

lxml vulnerable to Cross-site Scripting

Also known asGHSA-pgww-xf46-h92rPYSEC-2020-62
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2020-27783.

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.43%1.88%3.34%4.80%1.2%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍lxml

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A XSS vulnerability was discovered in python-lxml's clean module. The module's parser didn't properly imitate browsers, which caused different behaviors between the sanitizer and the user's page. A remote attacker could exploit this flaw to run arbitrary HTML/JS code.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIlxmlall versions4.6.2pip install --upgrade 'lxml==4.6.2'

Affected Products

8 products · 10 configurations
OS
debian linuxdebian
2 versions
9.010.0
OS
fedorafedoraproject
2 versions
3233
Application
lxmllxml
≥ 1.2 && < 4.6.2
range
Application
snapcenternetapp
all
Application
communications offline mediation controlleroracle
1 version
12.0.0.3.0
Application
zfs storage appliance kitoracle
1 version
8.8
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lxml, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update lxml to 4.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-27783 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux 8python27:2.7-8040020210122160212.cdb2db54RHSA-2021:1761
Red Hat Enterprise Linux 8python38:3.8-8040020210128125034.b1b639b6RHSA-2021:1879
Red Hat Enterprise Linux 8python-lxml-0:4.2.3-2.el8RHSA-2021:1898
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-python38-babel-0:2.7.0-12.el7RHSA-2021:3254

Frequently Asked Questions

A XSS vulnerability was discovered in python-lxml's clean module. The module's parser didn't properly imitate browsers, which caused different behaviors between the sanitizer and the user's page. A remote attacker could exploit this flaw to run arbitrary HTML/JS code.
O3 Security · Impact-Aware SCA

Is CVE-2020-27783 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2020-27783: lxml XSS — Fixed in 4.6.2