NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CakePHP vulnerable to Remote File Inclusion through View template name manipulationGHSA-p76f-wr22-4rv6

Fix: cakephp/cakephp@5e60cc5

GHSA-p76f-wr22-4rv6 is a security vulnerability in cakephp/cakephp. A fix is available for cakephp/cakephp — see the affected versions and patch details below.

Published
Updated
Affected
10 pkgs
Patched
10 / 10
Exploits
None indexed
Exploitation data as of Nov 29, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

10 pkgs affected
🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp🐘cakephp/cakephp+2 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

CakePHP 2.x prior to 2.0.99, 2.1.99, 2.2.99, 2.3.99, 2.4.99, 2.5.99, 2.6.12, and 2.7.6 and 3.x prior to 3.0.15 and 3.1.4 is vulnerable to Remote File Inclusion through View template name manipulation.

Affected Packages

10 total 10 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcakephp/cakephp≥ 2.0.0&&< 2.0.992.0.99composer require cakephp/cakephp:^2.0.99
🐘Packagistcakephp/cakephp≥ 2.1.0&&< 2.1.992.1.99composer require cakephp/cakephp:^2.1.99
🐘Packagistcakephp/cakephp≥ 2.2.0&&< 2.2.992.2.99composer require cakephp/cakephp:^2.2.99
🐘Packagistcakephp/cakephp≥ 2.3.0&&< 2.3.992.3.99composer require cakephp/cakephp:^2.3.99
🐘Packagistcakephp/cakephp≥ 2.4.0&&< 2.4.992.4.99composer require cakephp/cakephp:^2.4.99
🐘Packagistcakephp/cakephp≥ 2.5.0&&< 2.5.992.5.99composer require cakephp/cakephp:^2.5.99

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cakephp/cakephp to 2.0.99 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p76f-wr22-4rv6 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

CakePHP 2.x prior to 2.0.99, 2.1.99, 2.2.99, 2.3.99, 2.4.99, 2.5.99, 2.6.12, and 2.7.6 and 3.x prior to 3.0.15 and 3.1.4 is vulnerable to Remote File Inclusion through View template name manipulation.
O3 Security · Impact-Aware SCA

Is GHSA-p76f-wr22-4rv6 in your dependencies?

Find it across Packagist, including transitive dependencies.

CakePHP vulnerable to Remote File Inclusion through…