HTTP Request Smuggling in NettyGHSA-p2v9-g2qv-p635
Fix: netty/netty#9865GHSA-p2v9-g2qv-p635 is a CWE-444 vulnerability in io.netty:netty-handler. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for io.netty:netty-handler — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
io.netty:netty-handler☕org.jboss.netty:netty☕io.netty:nettyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
HttpObjectDecoder.java in Netty before 4.1.44 allows a Content-Length header to be accompanied by a second Content-Length header, or by a Transfer-Encoding header.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.netty:netty-handler | ≥ 4.0.0&&< 4.1.45 | 4.1.45io.netty:netty-handler:4.1.45 |
| ☕Maven | org.jboss.netty:netty | all versions | No fix |
| ☕Maven | io.netty:netty | all versions | No fix |
Affected Products
sparkapacheubuntu linuxcanonicaldebian linuxdebianfedorafedoraprojectnettynettyjboss amq clientsredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.netty:netty-handler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.netty:netty-handler to 4.1.45 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p2v9-g2qv-p635 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
OpenShift Container Platform ships a vulnerable netty library as part of the logging-elasticsearch5 container. ElasticSearch's security team has stated that the previous vulnerability, CVE-2019-16869, does not poses a substantial practical threat to ElasticSearch 6 [1]. We agree that this issue would be difficult to…
* Use HTTP/2 instead (clear boundaries between requests) * Disable reuse of backend connections eg. ```http-reuse never``` in HAProxy or whatever equivalent LB settingsSource: Red Hat security advisory for GHSA-p2v9-g2qv-p635 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| AMQ Clients 2.y for RHEL 6 | qpid-proton-0:0.30.0-4.el6_10 | RHSA-2020:0601 |
| EAP-CD 19 Tech Preview | netty | RHSA-2020:2333 |
| Red Hat AMQ | netty | RHSA-2020:0922 |
| Red Hat AMQ 7.4.3 | netty | RHSA-2020:1445 |
| Red Hat AMQ Online 1.3.3 GA | netty | RHSA-2020:0497 |
| Red Hat AMQ Streams 1 | netty | RHSA-2020:0939 |
| Red Hat Data Grid 7.3.6 | netty | RHSA-2020:2321 |
| Red Hat Decision Manager 7 | netty | RHSA-2020:3196 |
Frequently Asked Questions
Is GHSA-p2v9-g2qv-p635 in your dependencies?
Find it across Maven, including transitive dependencies.