CVE-2016-4970 is a high-severity (CVSS 7.5) CWE-835 vulnerability in io.netty:netty-handler. EPSS puts its 30-day exploitation probability at 11.3% (96th percentile). A fix is available for io.netty:netty-handler — see the affected versions and patch details below.
Loop with Unreachable Exit Condition in Netty
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.netty:netty-handler☕io.netty:netty-handlerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
handler/ssl/OpenSslEngine.java in Netty 4.0.x before 4.0.37.Final and 4.1.x before 4.1.1.Final allows remote attackers to cause a denial of service (infinite loop).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.netty:netty-handler | ≥ 4.0.0.Alpha1&&< 4.0.37.Final | 4.0.37.Finalio.netty:netty-handler:4.0.37.Final |
| ☕Maven | io.netty:netty-handler | ≥ 4.1.0.Beta1&&< 4.1.1.Final | 4.1.1.Finalio.netty:netty-handler:4.1.1.Final |
Affected Products
cassandraapachenettynettyjboss data gridredhatjboss middleware text-only advisoriesredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.netty:netty-handler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.netty:netty-handler to 4.0.37.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-4970 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.7.0 | netty | RHSA-2020:3192 |
| Red Hat JBoss A-MQ 6.3 | see advisory | RHSA-2017:0179 |
| Red Hat JBoss Data Grid 7.1 | see advisory | RHSA-2017:1097 |
Frequently Asked Questions
Is CVE-2016-4970 in your dependencies?
Find it across Maven, including transitive dependencies.