phpMyAdmin Cross-site scripting (XSS) vulnerabilityGHSA-mwm8-36c5-j5cf
MEDIUMFix: phpmyadmin/phpmyadmin@418aeeaGHSA-mwm8-36c5-j5cf is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in phpmyadmin/phpmyadmin. A fix is available for phpmyadmin/phpmyadmin — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadmin🐘phpmyadmin/phpmyadminReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in examples/openid.php in phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 allows remote attackers to inject arbitrary web script or HTML via vectors involving an OpenID error message.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.0&&< 4.0.10.16 | 4.0.10.16composer require phpmyadmin/phpmyadmin:^4.0.10.16 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.4&&< 4.4.15.7 | 4.4.15.7composer require phpmyadmin/phpmyadmin:^4.4.15.7 |
| 🐘Packagist | phpmyadmin/phpmyadmin | ≥ 4.6&&< 4.6.3 | 4.6.3composer require phpmyadmin/phpmyadmin:^4.6.3 |
Affected Products
leapopensuseopensuseopensusephpmyadminphpmyadminDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phpmyadmin/phpmyadmin, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update phpmyadmin/phpmyadmin to 4.0.10.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mwm8-36c5-j5cf is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-mwm8-36c5-j5cf in your dependencies?
Find it across Packagist, including transitive dependencies.